Jump to content
Changes to the Jaspersoft community edition download ×

Exports for reports containing HTML5 charts suddenly fails


chris.daculan
Go to solution Solved by lucianc,

Recommended Posts

Hi,

It has come to our attention that exports for a report containing HTML5 Charts has recently been failing.  We have done some investigation and this issue is related to a process which uses chromium to render report contents.  Can you please advise if there is any workaround for this issue?

Note: There are no useful logs on the server as we assume this is an internal issue for the interaction between chromium and the operating system components.   All we can see on the logs is something like below:

2023-03-15T02:07:57,880 ERROR SecureExceptionHandlerImpl,pool-14-thread-1288:116 - There was an error on the server. Try again or contact site administrators. (Error UID: 99892324-25f4-478f-8935-86347579abbf)[/code]

Attached sample screen below for visualization:
converted-file.png.aa796809606ec64e7b615aaaa46c334e.png

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Solution

Chromium 111 introduced a couple of incompatibilities with the library used to connect via the DevTools Protocol.

You can workaround the problem by adding the following properties to WEB-INF/classes/jasperreports.properties:

net.sf.jasperreports.chrome.page.isolate=truenet.sf.jasperreports.chrome.argument.remote-allow-origins=*[/code]

Regards,

Lucian

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...