Jump to content

fail to start JasperServer from running Tomcat


Enke

Recommended Posts

Hello all,

with my colleague we tried today to install JasperServer on Debian 10, using the existing Tomcat 9.0.46 and existing PostgreSQL. The installer finished without any errors, everyhing seemed to be fine, however the JasperServer did not launch and when attempting to start in manually from the Tomcat manager we get an error message FAIL - application at context path /jasperserver could not be started. We have gone through some other post with the same error but could not find a similar issue we have in the log (see attached). Its our first JasperServer installation and any pointer/help how to proceed will be much appreciated.

Thx

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi Enke, hope you solved your problem by now. 

If not, in your log file the clear issues is 
"Cannot load JDBC driver class 'org.postgresql.Driver' java.lang.ClassNotFoundException: org.postgresql.Driver"

So classpath problems with your postgressql driver. Either it is not loading or maybe the incorrect version etc. 
You may assign the correct version to your user envirnoment classpath and start up or in apache-tomcat/lib just drop the approriate driver jar for the given postgress. 
Should solve our problem. 
 

 ​​​​​​​

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...