Jump to content
Changes to the Jaspersoft community edition download ×

Export from Jasper Studio to Jasper Server

Go to solution Solved by matthayllar,

Recommended Posts

I've been trying to export a simple report from Jasper Studio to Jasper Server for a little over 3 hours now.  Report runs fine in Studio with 2 input params ---  start_time and end_time.

I've exported it to my Jasper Server that is running on the same machine.  I can see the report.  When I run it, I get "You must apply input values before the report can be displayed".  Only there is no place to enter input parameters.  Clicking the little 'input controls' button yields a useless, blank window.

All I can do is click "edit" on the report, and choose "controls and resources" on the left -- I see my two input params, and it's set to always prompt, as it should be.  There isn't anything else to configure in Jasper Server than I can see, so I'm guessing I need to do something else in Jasper Studio before I export.  I've experimented with the properties tags in the source frame in Jasper Studio....  I set the data adapter to be repo:<file location>    Does that force it to use an xml file in Jasper Server instead of something that has been manually setup as the data source?  The data source situation is extremely confusing, as the report already has it's data sources setup perfectly in Studio --- why on Earth should I have to create all of that again in Server?


Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

  • Solution

Port the report to Jasper Server by adding the jasper server connection from within Jasper Studio, then clicking the publish button.  It sounds confusing as hell, but you do NOT need to point to a datasource OR a query.  You are going to copy the dataset you're using in Studio to the Server and use that.

You DO need a data adapter setup in Jasper Studio ("Oracle.xml" is the one I've setup for myself).  when it is copied to J. Server, it will just look like the word "Oracle" with no extensions or anything.

When you click the publish button in Jasper Studio, it will show you a list of things that will be copied to Jasper Server.  The report itself, any connections you have (Oracle) and any images like PNG files that you have on your report.  It also strangely includes the report input parameters -- just let it copy them.  Note that the screen says to select them, but you can't select or deselect anything here.  You can click where they say "overwrite" and make sure that they all do say "overwrite" so that they definitely get copied.  Anyway, once that is complete, you'll see the report and "Oracle" in the same folder within Jasper Server.

The report only works when this "Oracle" file remains in the same folder as the Report file.  If you delete or move the "Oracle" file, your report will run on Jasper Server, but any parameters you have will stop showing up.  This was the problem I had.  To get that "Oracle" file to reappear (in the case that you accidentally deleted it), you'll have to go back to Studio and publish again. Click on "Overwrite only expression" next to "Oracle" and change it to "overwrite."  That will make sure that the file actually gets re-sent.

You can tweak your parameters by selecting the report in Server and clicking edit.  On the Edit page of the report on Jasper Server, we see TSALogo.png as a "resource".  This gets put there by the publishing process.  Removing that will break your whole report.

Then we have start_time and end_time as input controls, which are also put there by the publishing process.  (You can edit the text on these if needed while leaving the param name the same.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...