Jump to content
Changes to the Jaspersoft community edition download ×

Sorting issue when special charcter is there in the text value


balacs11

Recommended Posts


I am facing an issue with sorting the data when special character is there in the text value

My data looks like the below ,
Column name : Data
1.Value Sort 1
2.ValueSort1
3.Value!Sort1
4.Value#Sort1
5.Value_Sort1

I have sorting field "Data" set to Ascending

It sorts like the below,

1.Value_Sort1
2.Value!Sort1
3.Value#Sort1
4.ValueSort1
5.Value Sort 1

The encoding is UTF-8. 

Expected output:

1.Value Sort 1
2.Value!Sort1
3.Value#Sort1
4.Value_Sort1
5.ValueSort1

Any idea why it is happening like this?
 

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

  • 2 weeks later...

Thanks for the valueable inputs. 

I have tried these and finally ended up accepting the default behavior of Jaspersoft sorting.

1)Changing the encoding in server level - but didnt work

2)Moving the sort order to query - it works but my report requirement (Crystal report vs Jasper comparison )

In addition , It is a comparison between Crystal and Jasper reports. These two never gets same sort order even if the sorting is moved to query. 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...