Jump to content
Changes to the Jaspersoft community edition download ×

Ucanaccess Feature not supported


aamaa8
Go to solution Solved by aamaa8,

Recommended Posts

Hello,

I have tried to add a new Data adapter in Jaspersoft Studio to be able to use my Access database. These are the following details I have used:

JDBC driver: net.ucanaccess.jdbc.UcanaccessDriver

JDBC Url: jdbc:ucanaccess://D:/Database.accdb;memory=false

Driver Classpath: I have added the following JARs: "ucanaccess-4.0.4.jar", "commons-lang-2.6.jar", "commons-logging-1.1.3.jar", "hsqldb.jar", "jackcess-2.1.11.jar"

When I test it I get a Successful connection, however when I try to make a query I get this error:

net.ucanaccess.jdbc.FeatureNotSupportedException: Feature not supported.
    at net.ucanaccess.jdbc.UcanaccessDatabaseMetadata.getSchemas(UcanaccessDatabaseMetadata.java:923)
    at com.jaspersoft.studio.data.sql.ui.metadata.MetaDataUtil.readSchemas(MetaDataUtil.java:39)
    at com.jaspersoft.studio.data.sql.ui.metadata.DBMetadata.updateMetadata(DBMetadata.java:261)
    at com.jaspersoft.studio.data.sql.SQLQueryDesigner$4.runOperations(SQLQueryDesigner.java:299)
    at com.jaspersoft.studio.utils.jobs.CheckedRunnableWithProgress$1.run(CheckedRunnableWithProgress.java:51)
    at java.lang.Thread.run(Thread.java:748)

I have also tried iReport using netbeans and it works fine. But I want to try using Jaspersoft Studio instead as it has new features.

 

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

  • 1 year later...
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...