Jump to content

AWS jasperserver becomes unresponsive after editing pg_hba.conf and postgresql.conf files


Recommended Posts

Hi i actually needed to access jasperserver's associated postgresql and hence changed the postgresql.conf and pg_hba.conf files. soon i change them (as ec2-user) the jasperserver became unresponsive and started thrwoing error 404 resource not available.

Later i reverted the changes but still the jasperserver is responsive. I didnt take a snapshot before changing my bad!

note: I have checked the catalina.out and it was saying connection refused as error/exception.

any help on this is much appreciated.

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Did you restart postgresql after reverting it back to it's original value? Also, check postgresql log for any error.

JasperReports Server requires a database to startup and since it's not able to access the database, it's throwing 404 error.

Link to comment
Share on other sites

hi @hozawa, thanks i have checked if postgresql is up or not and it was down and when i checkd the postgresql log file it says there was a permission level change on those config files.

So i reverted the permission back to the postgres user and then tried to restart it worked!! Thanks @hozawa

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...