Jump to content
Changes to the Jaspersoft community edition download ×

every field appear blank. No error reported.


2004 IR Help

Recommended Posts

By: barachant Frederic - pepe_iolabs

every field appear blank. No error reported.

2005-09-16 07:41

Hello.

I have a report whose fields appear blank. It compiles correctly, shows no error, neither it shows while executing.

When the report gets generated, it shows the right row count, the right headers and footers, but every text field is printed empty.

The report used to work, stopped on a power failure. I replaced every files, jars, ... from dev machine and it didn't work any better.

Here is an exemple of what it shows. http://cyberproject-nimes.com/tarif.pdf

If anyone has a clue, please tell me. I think i tried everything possible.

 

 

 

 

 

By: barachant Frederic - pepe_iolabs

RE: every field appear blank. No error report

2005-09-16 08:09

Of course, anyone understanding French a bit can come to the website ( http://cyberproject-nimes.com ), press "imprimer un tarif", select categories in the treeview and generate the pdf.

The data used is the same as the browsable catalogue, thus i can ensure that the data is here.

XML file is generated and compiled through iReport 0.5.1, all text fields are green, no problem reported.

 

 

 

 

By: barachant Frederic - pepe_iolabs

RE: every field appear blank. No error report

2005-09-16 08:14

the link above was broken . please use

http://cyberproject-nimes.com/tarifs.pdf

 

Thanks a huge bunch

 

 

 

 

By: Teodor Danciu - teodord

RE: every field appear blank. No error report

2005-09-16 08:15

 

Hi,

 

It might be that the text fields that do not show up are

actually too small for the font size inside.

Try to make them a little taller by increasing the height

property with a few pixels.

 

I hope this helps.

Teodor

 

 

 

 

 

By: barachant Frederic - pepe_iolabs

RE: every field appear blank. No error report

2005-09-16 08:23

THAT'S IT !!!!!

 

I just tried with a smaller font (faster to test...)

 

i can't believe it's that sensible. I thought that eventually rendering would be truncated, but it was not.

Still, i wonder why the report used to work and why it now does not. I also wonder if the problem comes from jasperreport that does not generate data, of pdf viewer that does not show truncated fields.

 

THANKS THANKS THANKS..

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...