Jump to content
Changes to the Jaspersoft community edition download ×

Studio not connecting with server on another machine 403 forbidden


tabdelmonem
Go to solution Solved by hozawa,

Recommended Posts

Hey everyone,

I have been trying to connect Jasper studio 6.3 (Macbook Pro) to the Jasper server 6.3 (Windows Server 2012). I can bring up the server in my chrome browser on the mac, using the same the credentials and URL as I set within studio. Yet, I am receiving the following error:

AxisFault faultCode: {http://xml.apache.org/axis/}HTTP faultSubcode:  faultString: (403)Forbidden faultActor:  faultNode:  faultDetail:  {}:return code:  403<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>403 Forbidden</title></head><body><h1>Forbidden</h1><p>You don't have permission to access /:8080/jasperserver-pro/login.html/services/repositoryon this server.</p><hr><address>Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.12 Server at rghq-srv-rap Port 80</address></body></html>{http://xml.apache.org/axis/}HttpErrorCode:403(403)Forbidden at com.jaspersoft.ireport.jasperserver.ws.http.JSSCommonsHTTPSender$3.handleResponse(JSSCommonsHTTPSender.java:254) at com.jaspersoft.ireport.jasperserver.ws.http.JSSCommonsHTTPSender$3.handleResponse(JSSCommonsHTTPSender.java:1) at org.apache.http.client.fluent.Response.handleResponse(Response.java:90) at com.jaspersoft.ireport.jasperserver.ws.http.JSSCommonsHTTPSender.invoke(JSSCommonsHTTPSender.java:230) at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32) at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118) at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83) at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165) at org.apache.axis.client.Call.invokeEngine(Call.java:2784) at org.apache.axis.client.Call.invoke(Call.java:2767) at org.apache.axis.client.Call.invoke(Call.java:2443) at org.apache.axis.client.Call.invoke(Call.java:2366) at org.apache.axis.client.Call.invoke(Call.java:1812) at com.jaspersoft.ireport.jasperserver.ws.RepositorySoapBindingStub.list(RepositorySoapBindingStub.java:336) at com.jaspersoft.ireport.jasperserver.ws.WSClient.getVersion(WSClient.java:158) at com.jaspersoft.studio.server.protocol.soap.SoapConnection.getServerInfo(SoapConnection.java:113) at com.jaspersoft.studio.server.protocol.soap.SoapConnection.connect(SoapConnection.java:154) at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:110) at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:100) at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:102) at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:97) at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:76) at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)[/code]

I have read another post which pointed to different versions of studio & server will not work, but these are the same version, yet on two different computers with two different operating systems

Thanks in advance

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Thank you @hozawa, your answer of selecting "Ask Password" lead me to understanding the issue. Within the Account section, it was sending username and I changed it to jasperadmin, which lead to me selecting "Password" and filling in both username/password

Thanks you for your help

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...