Jump to content

Jasper Reports Server - Evaluation, unable to login


Recommended Posts


I have installed the evaluation copy of Jasper Reports Server on a Windows 2008 Server.  When I try and connect locally through http://localhost:8080/jasperserver-pro/login.html, the login button is disabled.  This implies the license isnt perhaps being recognised.  I tried to connect remotely to the PC over the network in case it was to do with browser versions, and cannot connect at all to http://serverX/jasperserver-pro/login.html, implying an inability to connect (which may be a separate issue, or somehow related).  I can ping the server and can connect remotely to port 80 to another http server (IIS).  I am connecting using superuser/superuser as per instructions.

Any help appreciated.  I see there is a folder called eval-licenses in the installation folder, but am not clear if there is any action for me to perform with these.



Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

It's probably not a license issue. License error results in an error messages saying license is invalid and do not show the login page.

First, try clearing your web browser's cache. If you've accessed different version of JasperReports Server, it may have cached some files which is different (because it's for a different version).

Second, go to where you've installed JasperReports Server. There should be apache-tomcatlog folder. Check the error messages.

There's also a log file under apache-tomcatwebappsjasperserver-proWEB-INFlogs

Link to comment
Share on other sites

Thanks, I will try tomorrow. Although this is a fresh windows install and the first attempt at installing JasperReports. I am curious as to why I cant connect to the tomcat instance from another machine, when I can connect on port 80 to an IIS website running on that box...is the evaluation restricted in terms of connectivity...not that I can connect ;-)


I also tried editing the tomcat-users.xml file to add a manager-gui role, but could not connect to the tomcat manager application.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...