Jump to content
JasperReports Library 7.0 is now available ×

Jaspersoft Studio: no markup processor factory specified


tadaskrisciunas
Go to solution Solved by tadaskrisciunas,

Recommended Posts

Hi,

I am designing a report using Jaspersoft Studio, and it all works fine until I use "Arange in Container" > "Horizontal Layout" from the context menu in a container. After I do this, report generation (in all formats I have checked: PDF, Java, HTML) starts to throw an error:

no markup processor factory specified for '' markup[/code]

with details as follows

net.sf.jasperreports.engine.JRRuntimeException: No markup processor factory specifyed for '' markup.    at net.sf.jasperreports.engine.fill.JRFillTextElement.getMarkupProcessor(JRFillTextElement.java:1034)    at net.sf.jasperreports.engine.fill.JRFillTextElement.processMarkupText(JRFillTextElement.java:1018)    at net.sf.jasperreports.engine.fill.JRFillStaticText.<init>(JRFillStaticText.java:52)    at net.sf.jasperreports.engine.fill.JRFillObjectFactory.visitStaticText(JRFillObjectFactory.java:645)    at net.sf.jasperreports.engine.base.JRBaseStaticText.visit(JRBaseStaticText.java:95)    at net.sf.jasperreports.engine.JRAbstractObjectFactory.getVisitResult(JRAbstractObjectFactory.java:89)    at net.sf.jasperreports.engine.fill.JRFillElementGroup.<init>(JRFillElementGroup.java:83)    at net.sf.jasperreports.engine.fill.JRFillElementContainer.<init>(JRFillElementContainer.java:90)    at net.sf.jasperreports.engine.fill.JRFillBand.<init>(JRFillBand.java:92)    at net.sf.jasperreports.engine.fill.JRFillObjectFactory.getBand(JRFillObjectFactory.java:505)    at net.sf.jasperreports.engine.fill.JRBaseFiller.<init>(JRBaseFiller.java:467)    at net.sf.jasperreports.engine.fill.JRVerticalFiller.<init>(JRVerticalFiller.java:89)    at net.sf.jasperreports.engine.fill.JRVerticalFiller.<init>(JRVerticalFiller.java:104)    at net.sf.jasperreports.engine.fill.JRVerticalFiller.<init>(JRVerticalFiller.java:62)    at net.sf.jasperreports.engine.fill.JRFiller.createFiller(JRFiller.java:179)    at net.sf.jasperreports.engine.fill.BaseFillHandle.<init>(BaseFillHandle.java:75)    at net.sf.jasperreports.engine.fill.AsynchronousFillHandle.<init>(AsynchronousFillHandle.java:98)    at net.sf.jasperreports.engine.fill.AsynchronousFillHandle.<init>(AsynchronousFillHandle.java:87)    at net.sf.jasperreports.engine.fill.AsynchronousFillHandle.createHandle(AsynchronousFillHandle.java:189)    at com.jaspersoft.studio.editor.preview.view.control.ReportControler$4.run(ReportControler.java:330)    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)[/code]

I need the report to work quite urgently, so please, help me!

I am working on Ubuntu 14.04 with the latest version of Jaspersoft Studio.

Thanks!

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • Solution

I have solved my own issue. If you have the same issue, go to the XML view and search for 'markup'. You will find something like this:

<textElement textAlignment="Center" verticalAlignment="Middle" markup="">[/code]

Change it to this:

<textElement textAlignment="Center" verticalAlignment="Middle" markup="none">[/code]

 

 

Link to comment
Share on other sites

  • 1 year later...
  • 3 years later...
  • 3 months later...
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...