Jump to content
Changes to the Jaspersoft community edition download ×

Getting "SyntaxError: missing ) after argument list" in visualize.js:59


hozawa

Recommended Posts

I just include visualize.js in an empy html page and there is a following error in the console. Has anyone actually got visualize.js packaged with JasperReport Server to work?

"SyntaxError: missing ) after argument list" in  visualize.js:59

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

I've tried loading from local filesystem, from Apache http server, and from putting them on the same application server as the JasperReports Server. The error, however, isn't about the server but about the syntax error in one of the Visualize.js script. The script file is loading but the web browser is complaining about the script having a syntax error.

I've used the JasperReports Server 5.6.0 upgrade war file.

I'll check if it's the file extracting error and also will try downloading the bundled installation package and see if I'll get the same syntax error problem.

Just wondering if anyone else is getting the same error.

The html file is like below so there's no other script nor tag that would cause syntax error.

<html>
<head>
<script type="text/javascript" src="http://localhost:8080/jasperserver-pro/client/visualize.js?logLevel=debug"></script>
</head>
<body>
Test
</body>
</html>
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...