Jump to content

Cannot connect to datasource in Jasper Studio 5.5.1

Go to solution Solved by hozawa,

Recommended Posts


I have just upgraded Jasper Studio from 5.5 to 5.5.1. When I try to preview my reports after the upgrade, I get an error saying that my database credentials are invalid. They worked before the Jasper Studio upgrade and I have tried to re-enter credentials, recreate data adapters and (of course) restart Jasper Studio - but nothing seems to help. How to manage this..?


Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Can you connect to your database using the 'root' user and the 'locahost' hostname from another program in your machine, you can test with http://squirrel-sql.sourceforge.net/

It is indeed strange that you where able to do it before and not know. Did anything else change after the upgrade?  

To better help you it will be good to know which database are you using and which driver.


Link to comment
Share on other sites

1) Yep, I can connect to the database using other programs (i.e. Mysql Query Browser). When I create the data adapter and press the "Test" button, I get a message saying that the connection attempt was successful. BUT when I edit my previously working data adapter I get the same error message as when I tried to preview the report. Could that mean that it is the storing of the password that fails..?

2) No, as far as I know, nothing else has changed

3) I am using MySql with the driver mysql-connector-java-5.1.14.jar


Link to comment
Share on other sites

  • Solution

Try opening up your data adapter with a text editor.

Change "savePassword" to "false"


Blank out the "password"


Also, check the "classpath" to make sure the path to the jdbc driver is correct.

Go back to studio and refresh and reopen the data adapter file. Enter the password again and see if that'll work.


Link to comment
Share on other sites

I tried to select the data adapter in the GUI and choose "Export to file", change the exported file and then choose "Import from workspace". Blanking out the password and setting savePassword to false doesn't seem to have any effect, but on the other hand do I not know how to refresh the settings...
Link to comment
Share on other sites

1) Exported data adapter to XML file

2) Made changes in the file BUT set savePassword to true and provided cleartext password straight in the file

3) Right-clicked the project and selected refresh

4) Right-clicked the data adapter and selected "Import from workspace"

5) Previewing the report works!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...