Jump to content

How to reference a Content Resource in a hyperlink


Recommended Posts

I uploaded a PDF document to the JasperReports Server as a Content Resource.  When I browse the repository, I can view it just fine.  Now what I want to do is add a hyperlink in a report that opens up the PDF file in another window.  The URL that is generated when I click on the document looks like this:


I tried to create a hyperlink with a type of Reference and used the URL above.  However, when I run my report and click on the link, I get a generic error "Internal server error occurred. Please contact your system administrator." There is no error number or details.  I also tried to use the ReportExecution hyperlink type but it generates an invalid uri message.  

How should content resources be referenced in a hyperlink?


Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

I think the ".PDF" would only be required if the resource ID contained it, which is the default behavior, but I removed it from the ID. I'm thinking the issue is related to the fact that I am running in multi-tenancy mode, which is why my path includes the "organizations/...", so I may have the path wrong. There is very little information on how the paths change when running multi-tenancy.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...