Jump to content
Changes to the Jaspersoft community edition download ×

Cannot upload JRXML file in repository


ehaque

Recommended Posts

 I am using Jasperserver 4.5 on Windows XP (SP3). I am trying to upload a JRXML file in repository and getting a error message "The file was not uploaded. Please try again. ". I also sent through log file anf found nothing. Can anyone please help me. 

I am also trying to upload/change jrxml file of created report but it is not working, even it is not providing any error message. However I can change/upload them by iReport.

 

Link to comment
Share on other sites

  • Replies 38
  • Created
  • Last Reply

Top Posters In This Topic

ehaque
Wrote:

Very strange behavier by Jasperserver 4.5

Sometimes I can be able to upload files(JRXML), sometimes not, both in LINUX and WINDOWS environment. No hints found in logs, no error megssage. In one world it's "mysterious".

Hi!

I have two identical virtual machines with Jasperserver 4.5, tomcat 7 and jdk1.7.0_02 on debian 6. In one of them I can upload the jrxml file but in the other one the same problem persist. 

Someone comes up with something to help?

Thanks in advance!

 

Link to comment
Share on other sites

I got this to work by editting the file:

WEB-INF/classes/esapi/security-config.properties

And setting:

security.validation.input.on=true

I had it set it to false previously in order to fix a bug in scheduled email. With a multi user  recipient list, scheduling breaks unless I set this to false.  So setting it to false fixed that bug and caused this one. Anyone else have a different fix for the email bug ?

Can you all check if you have this values set to false also ?

Link to comment
Share on other sites

brooneyx1
Wrote:

I got this to work by editting the file:

WEB-INF/classes/esapi/security-config.properties

And setting:

security.validation.input.on=true

I had it set it to false previously in order to fix a bug in scheduled email. With a multi user  recipient list, scheduling breaks unless I set this to false.  So setting it to false fixed that bug and caused this one. Anyone else have a different fix for the email bug ?

Can you all check if you have this values set to false also ?

Code:
Hi brooneyx1!That's it! I had the true value for that parameter because I had the problem of scheduling a report with more than one email address. Now it works! While not fix this problem, each time I have to upload the file jrxml I will put the value to true and after uploading to false.Many thanks for your post!!
Link to comment
Share on other sites

 

I have 2 versions of JasperServer 4.5 installed one in ubutunu and other in windows 7, the problem is that I can upload the report to JasperServer 4.5 on Windows but the same report I can not get on JasperServer in linux (ubuntu), error 1 -0. from iReport 4.5
If you are under 20k jrxml the report in linux it upload but if greater 20k error 1-0.
 
 

Please any solution,
 
 
regards,
 
Julian
Link to comment
Share on other sites

norcenmarco
Wrote:

Try to have the same version of jasperserver and iReport!!

And then let me know! Ok?

I wanna help you!! ;)

 

Cheers

Marco

 

Hi

I tried with the same version of Jasperserver and iReport but that didnt work for me. I have two installation of Jasperserver 4.5, one in Windows XP and another in Linux. Both showing the same behavior.

regards,

ehaque

Link to comment
Share on other sites

Hi All,

I'm also not able to upload the jrxml file to JasperServer and it not showing any error. It is just that JasperServer doesn't allow me to go to Data Sources window and the window refreshes with the upload file text box being blank.

My jrxml file size is 32 KB and I'm using the same versions of JasperServer and iReport designer(4.0.1)

Is there any solution to this problem??

Thanks in advance

LK

Link to comment
Share on other sites

 My jrxml is more 100kb ..... 

I currently used  the latest jasperserver 4.5 and  Jaspersoft iReport Designer 4.5.0.

My experience was JS 4.0.1 was problematic and so moved back to js3.7 

Now testing  JS4.5 !

 



Post Edited by chenny at 02/28/2012 13:06
Link to comment
Share on other sites

 LK,

 You did not indicate that you are unable to upload jrxml file via website. 

Yr JS should report any error unless you have disabled the logging.

As you have said that there is no error in JS, then you try to degrade your iReport.

If your JS is v4.0, have you try the iReport 4.0.2, 4,1  or even 3.7.6 or below?

If your JS is 3.1, any major release of iReport other than ir3.0  may not work. 

have you uninstall, delete all residual files and re-install as NEW ?

My experience is that I can download and cannot update or upload. Classpath, JVM Settings needs to be checked and corrected in the iReport. Otherwise ...hold on the working version.  

 

Chen

 



Post Edited by chenny at 02/29/2012 01:21
Link to comment
Share on other sites

 

When I’m try to login to the My Jaspersoft server in that Time i Face These below Error.

The server has encountered an error. Please excuse the inconvenience. An error has occurred. Please contact your system administrator. (5321)

 I have Chnged ,security.validation.input.on=false , in Below path

C:Program Filesjasperreports-server-4.5apache-tomcatwebappsjasperserver-proWEB-INFclassesesapisecurity-config.properties and setting:

Now My Jasper Soft Server Login Fine But I’m Facing One more  below Problem , the  Report Working Fine in IReport and same report upload in JasperSoftServer giving Problem.

 

RE: Cannot upload JRXML file in repository

 Error Message: Select a valid JRXML file

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...