Jump to content

NoClassDefFoundError :dori/jasper/engine/fill


Recommended Posts

By: prakash - prakash_p_23

NoClassDefFoundError :dori/jasper/engine/fill

2003-02-11 01:24

 

i am unable to get soln to this Problem.Following is stack trace

 

 

 

Error: 500

Location: /servlet/ReportGenrator1

Internal Servlet Error:

 

java.lang.NoClassDefFoundError: dori/jasper/engine/fill/JRVerticalFiller

at dori.jasper.engine.fill.JRFiller.fillReport(JRFiller.java:138)

at dori.jasper.engine.JasperFillManager.fillReport(JasperFillManager.java:348)

at ReportGenrator1.doGet(ReportGenrator1.java:79)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:405)

at org.apache.tomcat.core.Handler.service(Handler.java:287)

at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)

at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:812)

at org.apache.tomcat.core.ContextManager.service(ContextManager.java:758)

at org.apache.tomcat.service.connector.Ajp13ConnectionHandler.processConnection(Ajp13ConnectionHandler.java:160)

at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)

at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:501)

at java.lang.Thread.run(Thread.java:498)

 

 

 

 

 

 

By: Mirko Wawrowsky - mawawrowsky

RE: NoClassDefFoundError :dori/jasper/engine/

2003-04-03 06:22

I have the exactly same problem with websphere. Did anyone solve this?

 

java.lang.NoClassDefFoundError: dori/jasper/engine/fill/JRVerticalFiller

at dori.jasper.engine.fill.JRFiller.fillReport(JRFiller.java:138)

at dori.jasper.engine.JasperFillManager.fillReport(JasperFillManager.java:348)

at tsystems.its.maysis.web.ReportAction.perform(ReportAction.java:90)

at org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)

at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)

at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:509)

at javax.servlet.http.HttpServlet.service(Compiled Code)

at javax.servlet.http.HttpServlet.service(Compiled Code)

at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(Compiled Code)

at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(Compiled Code)

at com.ibm.servlet.engine.webapp.IdleServletState.service(Compiled Code)

at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(Compiled Code)

at com.ibm.servlet.engine.webapp.ServletInstance.service(Compiled Code)

at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(Compiled Code)

at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(Compiled Code)

at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(Compiled Code)

at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(Compiled Code)

at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.forward(Compiled Code)

at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(Compiled Code)

at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(Compiled Code)

at com.ibm.servlet.engine.invocation.CacheableInvocationContext.invoke(CacheableInvocationContext.java:106)

at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(Compiled Code)

at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(Compiled Code)

at com.ibm.servlet.engine.oselistener.SQEventListenerImp$ServiceRunnable.run(Compiled Code)

at com.ibm.servlet.engine.oselistener.SQEventListenerImp.notifySQEvent(Compiled Code)

at com.ibm.servlet.engine.oselistener.serverqueue.SQEventSource.notifyEvent(Compiled Code)

at com.ibm.servlet.engine.oselistener.serverqueue.SQWrapperEventSource$SelectRunnable.notifyService(Compiled Code)

at com.ibm.servlet.engine.oselistener.serverqueue.SQWrapperEventSource$SelectRunnable.run(Compiled Code)

at com.ibm.servlet.engine.oselistener.outofproc.OutOfProcThread$CtlRunnable.run(Compiled Code)

at java.lang.Thread.run(Compiled Code)

 

 

 

 

By: Tony Zahn - tzahn

RE: NoClassDefFoundError :dori/jasper/engine/fill

2003-04-03 10:49

I have the same problem. I've checked my classpath, and it's got jasperreports.jat, itext-0.96.jar, and all the jakarta commons .jar files. I've got no ideas what's going on here.

 

I'm running on a Solaris 8 machine, using JRun. I've gotten the compile script from the WebApp sample to work OK, but I'm getting this error on pdf.jsp.

 

It looks like some other people have gotten this problem, are you running anything similar systems-wise?

 

 

 

 

By: Tony Zahn - tzahn

RE: NoClassDefFoundError :dori/jasper/engine/fill

2003-04-03 10:47

I have the same problem. I've checked my classpath, and it's got jasperreports.jat, itext-0.96.jar, and all the jakarta commons .jar files. I've got no ideas what's going on here.

 

I'm running on a Solaris 8 machine, using JRun. I've gotten the compile script from the WebApp sample to work OK, but I'm getting this error on pdf.jsp.

 

It looks like some other people have gotten this problem, are you running anything similar systems-wise?

 

 

 

 

By: Teodor Danciu - teodord

RE: NoClassDefFoundError :dori/jasper/engine/fill

2003-04-03 12:05

 

Hi,

 

It appears that a possible solution for this is to

recreate the jasperreports.jar file like indicated

in the patch here:

 

http://sourceforge.net/tracker/index.php?func=detail&aid=640874&group_id=36382&atid=416705

 

I would like some feedback on this issue.

 

Thank you,

Teodor

 

 

 

 

 

By: Mirko Wawrowsky - mawawrowsky

NoClassDefFoundError :dori/jasper/engi SOLVED

2003-04-08 01:36

I found out that NoClassDefFoundError appears if no connection to X11 could be established. After starting the servlet engine, when the awt Toolset is initialized, an error message comes up that the connection to the X11 server is not possible.

If one tries a second time *without restarting the servlet engine* the misleading NoClassDefFoundError appears.

 

So if awt and x server cowork correctly the NoClassDefFoundError disappears.

 

Mirko

 

 

 

 

By: Tony Zahn - tzahn

RE: NoClassDefFoundError :dori/jasper/engine/fill

2003-04-03 14:05

Teodor,

 

I changed the line in the build XML from

<javac srcdir="./src" destdir="./classes" debug="true" optimize="false" deprecation="false">

to

<javac srcdir="./src" destdir="./classes" debug="true" optimize="false" deprecation="false" encoding="iso-8859-1">

 

and rebuild with "ant jar", but I'm still getting the same error. Could it make any difference that I'm using JDK 1.2.2 (I have to, that's what my version of JRun supports)?

 

Also, I'm building on my workstation (winXP), and copying the jar to the solaris machine, which is how I've been building all my servlets, so that shouldn't make any differences, but I figured I'd mention it just to be safe.

 

 

 

 

By: g dantas - gsdantas

RE: NoClassDefFoundError :dori/jasper/engine/fill

2003-04-10 14:26

I have the same problem running JDK 1.4 and SuSe. The got a solution by setting the JVM parameter -Djava.awt.headless=true

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...