Jump to content

UTF8 != UTF-8 Error

Recommended Posts

By: Guilherme Rios - gasrios

UTF8 != UTF-8 Error

2003-09-16 09:47



Maybe someone brought this one up before, but I really need a quick fix and have no time to browse all messages.

I sometimes get a SAXParseException from Crimson stating that "Declared encoding 'UTF-8' does not match actual one 'UTF8'; this might not be an error" (relevant parts of my stack trace attached to the end of this message). I get this Exception no mater which encoding my reports have.

JR was working fine on my development environment last Friday, but today something is wrong. I changed nothing but my classpath, which is supposed to be still pointing to the same versions of APIs in the same packages( I might have misplaced something though. Even if I did, I still get a clean compilation).

I've seen this happening with different versions of JR, commons Digester and Crimson. Right now I have the latest releases of each package. When it happens, I eventually come up with an ugly hack and get back on trail, but this has been bugging me for too long. The last thing I will try before hacking the code - I would like to do that more often in order to help the community, but really have no time right now - is asking here if someone knows what this is about, so if anyone have seen that before and could help me, I'd really appreciate it.






org.xml.sax.SAXParseException: Declared encoding "UTF-8" does not match actual one "UTF8"; this might not be an error.




















By: Patrick Vanhuyse - pvanhuyse

RE: UTF8 != UTF-8 Error

2003-09-19 01:01

I have had a similar problem but with Declared encoding "Cp1252".


When I run my application from my IDE (IntelliJ IDEA), it works fine but when I run it from the command line, I get the previous error.





By: Carmen Padilla Tejeda - mcptnix

RE: UTF8 != UTF-8 Error

2003-09-19 09:43

I have a similar problem but with this occurs when

my webapp is in Jrun in linux, but with Tomcat is ok.


I change the encoding in my xml, but again show this error, and change in the dtds files and i get another error


so if anyone have seen that before and could help me, I'd really appreciate it.



Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...