Jump to content

no data in server version of ireport ...


Recommended Posts


I have created a really simple report on the jasperserver using the ireport plugin that displays all fields from a table in an SQL Express database. When i run the report in ireport it displays all the data correctly. However, when i try to run the report from the jasperserver ui, i get the rows displayed but with no data values.

I'm pretty new to this stuff but have tried a variety of things with the datasource definitions and queries without any luck. As far as i can see, there are no errors generated.

Here is my datasource:

Driver: com.microsoft.sqlserver.jdbc.SQLServerDriver
URL: jdbc: sqlserver://computer-name:1433;Database=EngTraining

I have attached my jrxml file also.

I did find a similar question in the forum a few months back but i don't think it was resolved due to the posters poor english.

Any ideas or pointers to where i might start looking?

Ian. [file name=groups.jrxml size=7601]

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Don't i feel stupid :blush: After reading a couple of posts about font size i went back and modified the fonts of my data fields. Guess what! The data values suddenly appeared. :blush:

I guess there are some differences between ireport and jasperserver. Or perhaps it was because the jrxml did not define any fonts or styles.

Anyhow it appears to be working now.:)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...