Jump to content
Changes to the Jaspersoft community edition download ×

Reported timestamps off


vk01

Recommended Posts

Hi,

 

When I run a report from my pc, the timestamps are corrected, as queried in database. But when i run the same report from a development server, the timestamps are off by 13 hours, the minutes and seconds reported are corrected, just the hours.

 

Any clues or ideas very much appreciated. Totally lost at this point as to how to debug this issue.

 

Thanks a lot for your time.

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

vk01,

 

You said the difference was between "my pc" and "a development server". But is it also a difference between iReport on your PC vs JasperServer on the other server?

 

In that case the most common culprit is that the timezone for the data source on JasperServer is either set when it ought to be null or it's not set when it ought to be. (The former is probably the more common problem.)

 

Regards,

Matt

JasperSoft

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...