Jump to content
Changes to the Jaspersoft community edition download ×

iReport,JasperReports,pdf,iText-Where is the bug?


kasulas

Recommended Posts

I use iReports to develop the reports and deploy it in web application. Most part it works good except for text fields. From JRViewer previewer the text shows up good but when I save it to pdf using save icon, text is chopped, whole line is missing !!! However, from previewer if I say print and then choose pdf driver and generate a file, text shows up completely. This tells me it is not pdf bug.

 

I have searched this site for 2 days, seems a lot of people have come across this situation but I don't see a solution.

 

I have tried following things..

-specifying fonts directory location in classpath startup file.

-change font to true type font for pdf fonts, so that normal and pdf fonts match.

but still no success.

 

I have been using JasperReports for almost 2 years now but we are reaching a point where in I will have to drop this tool for good and move on to some other reporting tool. A year or so ago i had to convert 3 of my reports where I had to display a clob field to oracle to over come this problem. I don't want to redo the work in another tool.

 

any one, any advise on how to fix this!

 

thanks in advance.

Raj

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...