Jump to content
Changes to the Jaspersoft community edition download ×

Unable to start iReport on Linux


2006 IR Open Dicussion

Recommended Posts

By: Leo Geoffrion - ldgpangeo

Unable to start iReport on Linux

2006-05-15 11:28

This may be a dumb newbie question, but...

 

When I try to launch iReport using the iReport.sh script, it immediately dies with an error message of "Cannot find lib in iReport home directory (null)"

 

I've even tried setting it using the -ireport-home= flag but get the same error.

 

The same code works fine on Windows and MacOSX.

 

My Linux environment is Fedora Core 4.

 

 

 

 

 

 

By: Chris Collins - crusty_collins

RE: Unable to start iReport on Linux

2006-05-15 13:18

I get the same error but the app loads.

 

Cannot find lib in iReport home directory (null)

 

try and add -x to the bin/startup.sh and see if the script knows what EXEDIR is .

 

 

 

 

 

 

By: golablues - golablues

RE: Unable to start iReport on Linux

2006-05-16 10:56

I am having the problem, just installed on Fedora COre 5 with JDK 1.5..where do I add the -x? when running the script?

 

 

 

 

By: Richard Thorne - atoren

RE: Unable to start iReport on Linux

2006-05-18 22:33

Here is a hint that worked for me. If you are using the iReport.sh you need to chmod -R -x bin from the installation otherwise the iReport.sh doesn't can not execute the scripts inside the bin folder.

 

Richard

 

 

 

 

By: matias - el_itur

RE: Unable to start iReport on Linux

2006-06-12 15:46

I'm getting the same message on kubuntu jdk 1.4.2 and I already check those files as executable... I presume there is another way, some classpath that's not defined or something but just can't get it work. if somebody has an idea it will be welcome since I need to get iReports working quickly or I had lost a job.

 

Thanks

 

 

 

 

By: Tony - tt_linux

RE: Unable to start iReport on Linux

2006-06-12 23:54

hi,

check my post last week. may help you. i have a feeling the startup.sh and ireport.sh files were not transferred properly for linux use. The <cr<lf> ... maybe

i took a older addition (1.2.2 or 1.2.1) and it worked after that.

Obviously, do a chmod to make it executable.

Hope it helps.

 

 

 

 

By: matias - el_itur

RE: Unable to start iReport on Linux

2006-06-20 16:19

no, I' Already done that and I still get that message

 

 

 

 

By: matias - el_itur

RE: Unable to start iReport on Linux

2006-06-21 15:34

in fact I'm runnig ireport 1.2.2

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...