Jump to content
Changes to the Jaspersoft community edition download ×

Unable access WS on jasperintelligenge 1.0.1


ktrinad

Recommended Posts

By: Luca Gioppo - luca_gioppo

Unable access WS on jasperintelligenge 1.0.1

2006-07-21 02:49

Installed jasperIntelligence on JBoss 4.0.4 with MySQL.

The Web UI runs correctly, but when I try to use the web service (I wanted to try the php integration) it doesnt respond anything.

Chenged security to allow anon use and to give anon USER_ROLE.

I'm UNable to get the WSDL.

Tryed with:

http://localhost:8080/jasperserver/services/repository?wsdl

But got:

- <error>

<description>Unable to generate WSDL for this service</description>

<reason>Either user has not dropped the wsdl into META-INF or operations use message receivers other than RPC.</reason>

</error>

 

Where is the URL for WSDL?

Does the WS function or it's still in the work?

Thanks

Luca

 

 

By: Virulence - virulence

RE: Unable access WS on jasperintelligenge 1.

2006-07-23 18:26

I encounter same problem too

 

in http://localhost:8080/jasperserver/services/repository?wsdl

 

i got an error

 

<error>

<description>Unable to generate WSDL for this service</description>

<reason>Either user has not dropped the wsdl into META-INF or operations use message receivers other than RPC.</reason>

</error>

 

and in http://localhost:8080/jasperserver/view-services/JasperServerService?wsdl

 

it's fine.

 

tried making a simple php client accessing the latter, and got error

 

SOAP_Fault Object

(

[error_message_prefix] =>

[mode] => 1

[level] => 1024

Code:
 => WSDLPARSER 
[message] => Unable to parse WSDL file http://localhost:8080/jasperserver/view-services/JasperServerService?wsdl
XML error on line 15: Mismatched tag

is this the WS fault, or issit possible an error somewhere in the installation?


By: medspx - medux
RE: Unable access WS on jasperintelligenge 1.
2006-08-07 02:27
Hello,

I've got the same error. The problem comes from the fact that you shoudl authenticate yourself in order to reach the WSDL file returned by the server.

When trying to get the WSDL file, I've got the following error:
<html><head><title>Apache Tomcat/5.5.17 - Rapport d'erreur</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>Etat HTTP 500 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Rapport d'exception</p><p><b>message</b> <u></u></p><p><b>description</b> <u>Le serveur a rencontré une erreur interne () qui l'a empêché de satisfaire la requête.</u></p><p><b>exception</b> <pre>org.acegisecurity.AuthenticationCredentialsNotFoundException: An Authentication object was not found in the SecurityContext
org.acegisecurity.intercept.AbstractSecurityInterceptor.credentialsNotFound(AbstractSecurityInterceptor.java:329)
org.acegisecurity.intercept.AbstractSecurityInterceptor.beforeInvocation(AbstractSecurityInterceptor.java:244)
org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:104)
org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
com.jaspersoft.jasperserver.api.metadata.user.service.impl.MetadataAuthenticationProcessingFilter.doFilter(MetadataAuthenticationProcessingFilter.java:136)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:181)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:195)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:90)

And the NuSoap wsdl parser is not able to understand it. I'am trying to find a way to get the wsdl file from PHP after authentication.


By: Drooler - bhaugland
RE: Unable access WS on jasperintelligenge 1.
2006-08-07 05:47
I had the same problem under JBoss. You will need to alter the login-config.xml which is located in the conf area of your server.

At the bottom is an application-policy section named other. Change its contents to look like this

<authentication >
<login-module code="org.jboss.security.auth.spi.DatabaseServerLoginModule" flag="required>
<module-option name="dsJndiName">java:/jdbc/jasperserver</module-option>
<module-option name="principalsQuery">select password from JIUser where username = ?</module-option>
<module-option name="rolesQuery">select rolename, 'Roles' from JIUser, JIRole, JIUserRole where JIUser.username = ? and JIUserRole.userId = JIUser.id and JIUserRole.roleId = JIRole.id</module-option>
</login-module>
</authentication>

Note: I am using Oracle so if you are using my sql the table names are different.

This will allow you to access the WSDL for view-services/JasperServerServices?wsdl. The services/repository?wsdl does not seem to be working.


By: medspx - medux
RE: Unable access WS on jasperintelligenge 1.
2006-08-07 05:59
Hello,

I found another method by altering the configuration of the Acegi (WEB-INF/applicationContext-security.xml):
I've changed the bean filterChainProxy: replace "basicProcessingFilter,JIAuthenticationSynchronizer" by "anonymousProcessingFilter" for the /view-services/** line.

Then , in the same file I add anonymous access to the filterInvocationInterceptor bean:
/view-services/**=ROLE_USER,ROLE_ANONYMOUS

Then restart tomcat and WSDL file can be accessed anymously. NuSoap is then able to parse the wsdl file...
Link to comment
Share on other sites

  • 2 years later...
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

  • 1 month later...

shivareddyk : your problem has nothing to do with web services, which was the original issue in this thread.

 

Are you trying to log in automatically with some provided user name and password to avoid the login page? You can do this with something like:

 

http://mymachine:8080/jasperserver-pro/flow.html?_flowId=homeFlow&j_username=username&j_password=password

 

Sherman

Jaspersoft

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...