Spring Security

JasperReports Server currently uses Spring Security 4.2. If you are upgrading from an earlier version of JasperReports Server, you may need to migrate your configuration files. See the JasperReports Server External Authentication Cookbook, available from the support portal or the community website.

JasperReports Server relies on Spring Security 4.2 to provide the mechanisms that authenticate and authorize users. If you plan to make extensive customizations, we recommend that you delve more deeply into Spring Security by visiting its project pages and participating in its community. For more information, see the Spring Security website Spring Security website and refer to the documentation for Spring Security 4.2:

https://docs.spring.io/spring-security/site/docs/4.2.4.RELEASE/reference/htmlsingle/

Version: 
Feedback