Symptom
After successfully installing JasperReports Server v5.6.1, using the bundled installer, and starting JasperReports Server, the user is not able to access the application from a browser using http://<hostname>:8080/jasperserver-pro. Instead, an error is displayed in the browser:
Unable to connect Firefox can't establish a connection to the server at localhost:8080
Reviewing apache-tomcat log, user will find the following information:
INFO: Initializing ProtocolHandler ["http-apr-8081"]
Cause
When using “Install All Components and Samples Option” for JasperReports Server v5.6.1 bundled installation, the installer will attempt to find open Tomcat ports in the 8080 and higher range. It will assign the Connector port to 8081 should 8080 is already used by another application on the server.
Prior to JasperReports Server v5.6.1, this default port alternation only occurs during the installation when the server using port 8080 is up and running. In JasperReports Server v5.6.1 bundled installation, if user had another JasperReports Server instance installed using port 8080, even this instance is not up and running during the JasperReports Server v5.6.1 installation, the new JasperReports Server v5.6.1 http port is still get reassigned to 8081 or higher.
Resolution:
Changing the URL http port number to match the one found in apache-tomcat log file (or http Connector port setting in server.xml file under bundled installation root apache-tomcatconf directory) should resolve this issue.
For example:
http://<hostname>:8081/jasperserver-pro
TTC-20140921
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