iReport Install Problem: "Cannot find Java.exe"

0

Hi Everyone -

I'm new to iReport... I have a new Windows 7 PC  with very few programs installed (except MS Office 2007, Visual Studio 2008 and Visual Foxpro 9.2 )machine... I installed the latest build of iReport (Windows stand-alone version).

Everything appeared to install correctly ... however.. when I attempted to run the program, I get the following error:

"Cannot find java exe."

"Neither (null)\\jre\\bin\\java.exe nor (null)\\vin\\java.exe exists"

My question is:  Even though I installed the "stand-alone" version ... do I have-to install additional files? 

If so... which, and where can I find them?

Thanks for any help you can give me!

tomking23's picture
Joined: Feb 14 2010 - 2:45pm
Last seen: 6 years 9 months ago

11 Answers:

6
Code:
just setup the JAVA_HOME 
Environmental variable with the following path.
 
C:\\Program Files\\jasperserver-pro-3.7\\java\\jre
 
You will be alright. Refer to the screenshot.</td></tr></tbody></table>
arundba's picture
91
Joined: Feb 11 2010 - 9:40am
Last seen: 6 years 10 months ago
0

Thank you very much for your response...

I had to "ADD" the Environmental variable... to the system properties... as it was not in the list at all ... however... nothing happened...

When I try to run iReport... I still get the "Cannot find Java.exe..." error.

Moreover... I don't even have the directory referenced in the environmental variable you suggested I add... iReport didn't install that directory (see attached picture of my directory) ...

Do I need to install JasperServer and/or JasperReports, in addition to iReport... to get the necessary support files to run iReport?

Thanks again ... !



Post Edited by tomking23 at 02/15/2010 03:24
tomking23's picture
Joined: Feb 14 2010 - 2:45pm
Last seen: 6 years 9 months ago
1
hi tom,

you don't need to install jasper server.

search for java.exe on your system. Set that as the JAVA_HOME variable.

once you point the java. you should be able to run ireport.
i have iReport on windows 7 pro.
arundba's picture
91
Joined: Feb 11 2010 - 9:40am
Last seen: 6 years 10 months ago
0
if you don't have java on your system, you have to download and install it.
jre5 or jre6 will also do.
arundba's picture
91
Joined: Feb 11 2010 - 9:40am
Last seen: 6 years 10 months ago
0
Thanx Guyz I got my Ireport 3.7.3 working following your advice
tjnas's picture
1
Joined: Jul 3 2010 - 1:30pm
Last seen: 6 years 5 months ago
0

I have win 7 x64 and Jre x64 intalled. IReport 4.0.2 installed.

Still I receive the eror instead JAVA_HOME path sugested.



Post Edited by juvesoft at 07/01/2011 23:38
juvesoft's picture
Joined: Apr 30 2010 - 5:43am
Last seen: 6 years 7 months ago
10

I'm using win 7 64bit. I installed iReport 4.5 (release on today - 8 Dec 2011) & it brings to me the same result.
As what I see:

+Reason:
The iReport (in "C:Program Files (x86)JaspersoftiReport-4.5.0binireport.exe" for my case) look up absolute name of jre & jdk folders (not something like jre7 or jdk1.7.0_01 folder in installed Java folder, in this case I install the Java Platform (JDK) 7u1)

+ Solution

1st way:
set JAVA_HOME in system variables to your installed Java folder but you have to be sure there are absoulte jre & jdk folders not the jre_x/jdk_x where x is the verion of java runtime as stated above)

I prefer the 2nd way which is more flexible & can allow to use multiple java runtime

2nd way:

Set up the jdkhome in (installed Jaspersoft folder)iReport-4.5.0etcireport.conf to your installed Java folder.Example for my case:

step1: create a new folder, eg: "C:Program FilesJavaforJasper45"

step2: copy jre7 & jdk1.7.0_01 to that folder then rename to jre & jdk repectively

step3: add this line in the ireport.conf

jdkhome="c:Program FilesJavaforJasper45"

Then it works for me

Code:
Here is the content of my ireport.conf file:
 
# ${HOME} will be replaced by user home directory according to platform
default_userdir="${HOME}/.${APPNAME}/4.5.0"
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/4.5.0"
 
# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding ireport -J-Xms256m -J-Xmx512m -J-Dorg.netbeans.ProxyClassLoader.level=1000 -J-XX:MaxPermSize=512m"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea
 
# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch
#jdkhome="/path/to/jdk"
 
jdkhome="C:Program FilesJava4StupidJasper45"
 
# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)
#extra_clusters=



Post Edited by aoopvn at 12/09/2011 06:02



Post Edited by aoopvn at 12/09/2011 06:03
aoopvn's picture
79
Joined: Dec 8 2011 - 9:50pm
Last seen: 5 years 1 day ago

His solution sounds good, but don't have effect in windows 8

istrak23 - 3 years 9 months ago

Im on windows 8 and it worked. thank you!

y.sarvinia - 2 years 3 months ago
2

SET Environment Variable with:

JAVA_HOME = E:\Program Files\Java\jre7

or C:\Program Files\Java\jre7

 

where java.exe can be found in X:\Program Files\Java\jre7\bin\java.exe

transcend3nt's picture
Joined: Sep 25 2013 - 9:02am
Last seen: 3 years 2 months ago

the last solution work good in windows 8. Only edit the ireport.conf in notepad++ in administrator status

cstevenshermosilla - 1 year 8 months ago
2

u just see this video on youtube: https://www.youtube.com/watch?v=U0Pm71_dL_8

it's so helpfull

khireddine.treeteq's picture
Joined: Apr 21 2014 - 5:19am
Last seen: 1 month 5 days ago
0

It works.... check this link

https://www.youtube.com/watch?v=U0Pm71_dL_8
mayur321's picture
Joined: Aug 10 2016 - 10:34am
Last seen: 3 months 4 weeks ago
0

Hi 

This is because it needs the JRE (Java Runtime Enviroment) which is not installed on your pc or if it is installed then the environment variables are not set.

Solution

Hard = Set the environment variables which most people don't know i dont mean every one so dont get me wrong.

Easy = Install the latest JRE from this link https://www.java.com/en/download/ 

The installation will set every thing and you are done and good to go.

mynameisalam's picture
Joined: Oct 23 2016 - 3:03am
Last seen: 1 month 2 weeks ago
Feedback