JasperServer SVN Source Available

0

The JasperServer team is pleased to announce that the JasperServer source code is now publicly available. You can check out the HEAD source code using svn or you can directly navigate and view files via your browser. To check out or browse source files, go to the JasperServer project and click on the "Source" menu item. You can checkout source with a recommended command such as:   svn checkout --username anonsvn http://jasperforge.org/svn/repos/jasperserver/trunk jasperserver   Additional Maven dependencies are in the JasperForge Maven repository. You can set up your Maven environment in the .m2/setttings.xml to use it as follows:

 

Such as:

            <repository>

              <id>JasperForge Maven Repository</id>

              <!-- note: you need a <server> definition at bottom of file this file -->

              <url>http://anonsvn:anonsvn@jasperforge.org/svn/repos/maven2</url>

              <snapshots>

                <enabled>true</enabled>

              </snapshots>

              <releases>

                <enabled>true</enabled>

              </releases>

            </repository>

 

Then at bottom of file:

 

     <server>

        <id>JasperForge Maven Repository</id>

        <username>anonsvn</username>

        <password>anonsvn</password>

     </server>    

There is the JasperServer-Source-Build-Guide.pdf, which can be found in the downloads area. I tells how to build source that is downloaded as a zip and in Appendix C, how to build the public SVN source code. The public source code is a mirror that is updated hourly from the Jaspersoft internal svn repositories.

 

Enjoy!

Post Edited by Tony Kavanagh at 09/16/08 19:15

Post Edited by Sherman Wood at 04/03/09 03:02



Post Edited by tkavanagh at 05/20/2009 17:16
tkavanagh's picture
1096
Joined: Jul 7 2006 - 8:54am
Last seen: 1 month 2 weeks ago

10 Answers:

0
I'm trying to build off the trunk now, but I'm unable to find the file 'jasperserver-repo.zip' mentioned above. Can you be more explicit where to download it from? Thanks!
ljacobson's picture
Joined: Sep 12 2008 - 11:03am
Last seen: 6 years 1 month ago
0
Yes, it's in the downloads area: http://sourceforge.net/project/showfiles.php?group_id=162962&package_id=... Also, everything should just resolve because the suggested maven setup points to www.jasperforge.org/maven2 which holds the same set of jars.
tkavanagh's picture
1096
Joined: Jul 7 2006 - 8:54am
Last seen: 1 month 2 weeks ago
0

Both the file up at sourceforge and the jasperforge maven repo do not have jars for the 3.1.0 branch.  For example, the jasper reports dependencies are:

js-pro-3.1 tagged branch

    <dependency>       <groupId>jasperreports</groupId>       <artifactId>jasperreports</artifactId>       <version>3.1.2</version>     </dependency>

On jasperforge, the jasperreports jar only is valid up to  3.0.0.1

http://jasperforge.org/maven2/jasperreports/jasperreports/maven-metadata.xml

Building from 3.0.0 tagged branches seem to work, but we are running up against a bug in 3.0.0 that appears fixed in 3.1.0.  3.1.0 is a recent release, but is there a possiblity of the jasperforge maven repository being updated to keep in sync, or a new repo archive being made availble for download?



Post Edited by Greg Ludington at 11/26/08 20:04
gludington's picture
Joined: Nov 19 2008 - 4:32pm
Last seen: 1 year 7 months ago
0

Hi Greg, yes, the SVN public source has a problem because our maven2 remote repository (on jasperforge.org) is not working. So, the artifacts you mentioned are not getting resolved. I have this scheduled to be fixed.

But the good news is that I just posted the src package that always goes with the 3.1.0 release. Look for the file jasperserver-3.1.0-src.zip. Inside the zip you will find:

  /jasperserver             (3.1 src)

  /jasperserver-repo   (all required 3rd party dependencies)

So, go ahead and give the source a try. Sorry for the delay on this ... this all dropped in the middle of the holidays over here!

Thanks,

-Tony

P.S. The public SVN source has been tagged js-3.1.0. So, you will find the tag at:

 jasperserver/tags/js-3.1.0

tkavanagh's picture
1096
Joined: Jul 7 2006 - 8:54am
Last seen: 1 month 2 weeks ago
0

Hi,

I have some modifications of jpivot and mondrian based on the actual Versions from sf.net. I'd like to Integrate them into JasperServer. The componenents in JasperServer seem to be modified or have different Versions. Where can I find the sources used in Jasperserver 3.0 and 3.1?

One of the changes is extremely useful in our internal use: A filter symbol is displayed near each Dimension member. It acts as a quickly defineable filter. ( See Quickfilter.png)

I'd like to put the changes upstream. And I need them in JasperServer.

 

Where can I find the sources of jpivot and mondrian which are "plug-in-compitible" to JasperServer?

 

Thanks,

Jörg

jsb's picture
jsb
1
Joined: Dec 12 2008 - 3:00am
Last seen: 5 years 10 months ago
0

Up to JasperServer 3.1, JPivot has been changed from the base JPivot 1.7 version to work in JasperServer, to get Spring configuration and internationalization. We have a separate internal source tree, which we need to publish like we have for JasperServer.

 

Mondrian is the base 2.3.2 version.

 

I am in the process right now of upgrading Mondrian to v3.0.4 and doing the associated JPivot changes. Additionally, I am moving the JPivot changes we have done in JasperServer Professional into the community edition - a bit better navigation with popups rather than embedded forms, and being able to save an analysis view. This will be released in March.

 

I don't see any difference between your filter and a drill replace. Am I not understanding something?

 

Sherman

Jaspersoft

swood's picture
2049
Joined: Jun 21 2006 - 12:48pm
Last seen: 2 years 3 days ago
0

Hi,

 

I tried to build jasperserver for glassfish V2. It doesn't work.

i created the mysql databases and tables, only the jasperserver database layout is unknown to me. I used the scripts for sugarcrm and foodmart they worked correct. 

On glassfish i get a 503 error: descriptionThe requested service () is not currently available.

i searched some directories and discovered that the application.xml file in the jasperserver directory contained false information?

in my opinion the jasperserver-pro names are false.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<application xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.or
g/2001/XMLSchema-instance" version="1.4">
  <description>jasrepserver-pro</description>
  <display-name>jasrepserver-pro</display-name>
  <module>
    <web>
      <web-uri>jasrepserver-pro</web-uri>
      <context-root>/jasrepserver-pro</context-root>
    </web>
  </module>
</application>
</td></tr></tbody></table>
madmax--007's picture
Joined: Jan 10 2009 - 2:56am
Last seen: 5 years 9 months ago
0

In case it's not obvious to anyone else (this took me a few minutes), the password is the same as the username (anonsvn).

jdolan's picture
3
Joined: Jan 9 2009 - 1:42pm
Last seen: 5 years 9 months ago
0

When I download the jasperserver-3.1.0-src.zip  from the " http://sourceforge.net/project/showfiles.php?group_id=162962&package_id=... "

The file names are incomplete for the hibernate xml files  ie. it should  ***.hbm.xml and not  ***.hbm

 

The path is:   jasperserver-3.1.0jasperserverjasperserver-repository-hibernatesrcmainresourcescomjaspersoftjasperserverapimetadatacommonserviceimplhibernatepersistent

 

Please correct it and upload it and let us know once that is done...

vsoneta's picture
63
Joined: Feb 4 2009 - 5:50am
Last seen: 5 years 8 months ago
0

vsoneta Wrote:

The file names are incomplete for the hibernate xml files  ie. it should  ***.hbm.xml and not  ***.hbm

I downloaded the zip and the file names are correct.  Are you sure your zip tool or file navigator doesn't hide the .xml entension?

Regards,

Lucian

lucianc's picture
5279
Joined: Jul 17 2006 - 1:10am
Last seen: 1 month 3 weeks ago
Feedback
randomness