How to pass a parameter of a ad-hoc report from URL

0

I need to pass parameters through URL in the report created from adhoc view  using the domain.I used the example given in below link.The problem is that the Sales_stage_1 filter does not refresh.Even when i change the value in URl from Qualification to something else ,it still gives me the same result back which is saved in the report.I did try to change the setting in the XML file to always prompt to be true.What am i doing wrong? I am very new to Jasper, though have experience with other BI tools

Thank you

http://community.jaspersoft.com/blog/tip-how-pass-parameter-ad-hoc-repor...

ritugoyalgupta's picture
Joined: Feb 12 2017 - 1:32pm
Last seen: 1 month 4 days ago

1 Answer:

0

HI,  I was struggling with this and think I have found the answer. I had a filter which I set up in the AdHoc view which I created the report from.  I want to pass the parameter for that filter into the report using a URL.  This is the solution I found:

 - export the report (right click>export). 

 -  find the file: TopicJRXML in the zip file which downloads.

 - find the parameter name of the relevant filter. Its in the first few lines of the code.  In my case the field dispalyed as 'record_id'......the paramter name was actually 'record_id4_1'

 - append the parameter to your URL using the name you found in the Topic file as follows (using my example): ......&record_id4_1=CRM-0000003

That worked for me.  I haven't tried anything more complex like multi-selects or ranges, but I think it should work as per the guidance. Its just about finding the correct parameter name.  Unfortunately it doesn't tell you when you have the URL wrong, just defaults to the saved version of the report, which I suppose is useful in some ways but not that helpful when trying to get this right.

Good luck, let me know if you find any other useful tricks here as I am trying to get this to work too!

Thanks

Jason

jason.symons's picture
Joined: Mar 30 2016 - 5:03pm
Last seen: 1 week 5 hours ago
Feedback