[#9341] - Failure to connect with BI (6.2) windows environment

Category:
General
Priority:
High
Status:
Resolved
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
N/A
Assigned to:
0

Our application is failing to connect with BI when testing the authentication with an error signature that looks like this:

[13/Mar/2017:09:42:18 -0500] "POST /bso-bip-1400-bsoheadqa/rest/login?j_username=[PROCESSED]ENIPwvUs9a7g&j_password=[PROCESSED]M5QNzvQ66buh2oc HTTP/1.1" 401 12

We’ve completed extensive local testing of our application and are certain the problem doesn’t exist there.

So the question is what needs to be modified in BI/Windows to allow that REST login call to work correctly.

v6.2
dawaimrin's picture
Joined: Nov 13 2014 - 4:39pm
Last seen: 3 months 1 week ago

1 Comment:

#1
  • Resolution:Open» Unable to Reproduce
  • Status:New» Resolved
  • Assigned:» chicuslavic

from your error I see you get http code 401

401 UNAUTHORIZED
The request has not been applied because it lacks valid authentication credentials for the target resource.

The server generating a 401 response MUST send a WWW-Authenticate header field1 containing at least one challenge applicable to the target resource.

If the request included authentication credentials, then the 401 response indicates that authorization has been refused for those credentials. The user agent MAY repeat the request with a new or replaced Authorization header field2. If the 401 response contains the same challenge as the prior response, and the user agent has already attempted authentication at least once, then the user agent SHOULD present the enclosed representation to the user, since it usually contains relevant diagnostic information.

probably your credentials are not good, you should call support

Feedback
randomness