[#8931] - Java Classpath cannot be set in jasper studio

Category:
Bug report
Priority:
High
Status:
Closed
Project: Severity:
Block
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

Hi,

As of JasperReport studio 6.3.1, I'm not able to set java classpath for my project.
I tried:
-adding java files to the src folder,
-adding the class files to the build folder
-adding jar to a user defined library (workspace level),
-switching to java view (right clicking the project, build path option is enabled but no option comes up).

In every case, when I try to compile the project, it can't find the business specifig classes.

I couldn't find any reference or bug report regarding this matter.
Any help would be appreciated.

v6.3.0
rsisto's picture
2
Joined: Oct 7 2011 - 9:39am
Last seen: 1 month 1 week ago

4 Comments:

#1
  • Status:New» Feedback Requested

Hi,
it's not clear what you mean with "I can't find the business specific classes". Do you mean that you are not able to see the .class files?
In order to see them you should open the Navigator view from Window > Show View menu. After that looking into the project you should usually find the classes inside the bin folder (i.e when src files are compiled).
A part from this in order to set the classpath you can as usual (I assume you have a little knowledge of Eclipse) right click on the project:
1. Build Path > Configure Build Path...
2. Properties > Java Build Path
Please be sure to have the Java Development capabilities enabled from the Preferences > General > Capabilities. This unlocks a lot of menu items and actions related to Java development.

Best regards,
Massimo.

#2

Seems I'm struggling with the same problem. Built a custom function importing org.apache.commons.io.IOUtils, which compiles with no errors (Java capabilities enabled as told in the tutorial). When I try to use this function in an expression and open the report preview, It get an error

Caused by: java.lang.NoSuchMethodError: org.apache.commons.io.IOUtils.toString(Ljava/io/InputStream;Ljava/nio/charset/Charset;)Ljava/lang/String;

Already tried any known way to include commons-io-2.5.jar in the classpath, which obviously work when building the JasperReports extension. However, the build path seems not being considered by the report builder.

This is REALLY frustrating, having spent SEVERAL hours on this issue. Thanks for any workaround/bugfix!!!

#3

Is there any news on this topic ?
This blocking bug is referenced for a very long time now ! (http://community.jaspersoft.com/questions/539641/including-jar)

When will it be resolved ?

#4
  • Resolution:Open» No Change Required
  • Status:Feedback Requested» Closed
  • Assigned:» chicuslavic

If you use JSS as a stand alone application, by default java capability is disabled. To enable it, go to Properties->General->Capabilities check Development->Java

To setup java classpath in eclipse, look here https://help.eclipse.org/neon/topic/org.eclipse.jdt.doc.user/reference/p... . You can search internet for many use cases and how to setup classpath in eclipse, basically all cases should be covered.

Feedback