[#4096] - Custom visualisation Component Error

Category:
Bug report
Priority:
Immediate
Status:
New
Project: Severity:
Critical
Resolution:
Works as Designed
Component: Reproducibility:
N/A
Assigned to:
0

i am trying to upload samples of custom visulisation component on jasper server(compiled fine on studio) it is generating an error("INVALID JRXML")
i followed all steps to configure server(6.0) to upload custom component still error is persistent
please help
Error:
org.apache.http.client.HttpResponseException: Invalid JRXML
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleErrorDescriptorList(RESTv2ExceptionHandler.java:87)
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleErrorDescriptor(RESTv2ExceptionHandler.java:104)
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:56)
at com.jaspersoft.studio.server.protocol.restv2.ARestV2ConnectionJersey.toObj(ARestV2ConnectionJersey.java:52)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.addOrModifyResource(RestV2ConnectionJersey.java:445)
at com.jaspersoft.studio.server.protocol.ProxyConnection.addOrModifyResource(ProxyConnection.java:290)
at com.jaspersoft.studio.server.WSClientHelper.saveResource(WSClientHelper.java:282)
at com.jaspersoft.studio.server.WSClientHelper.saveResource(WSClientHelper.java:238)
at com.jaspersoft.studio.server.wizard.resource.AddResourceWizard$1.run(AddResourceWizard.java:196)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1028)
at com.jaspersoft.studio.server.wizard.resource.AddResourceWizard.performFinish(AddResourceWizard.java:178)
at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:827)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:432)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
at org.eclipse.jface.window.Window.open(Window.java:801)
at com.jaspersoft.studio.server.action.resource.AddResourceAction.run(AddResourceAction.java:70)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at com.jaspersoft.studio.pro.rcp.JSSProApplication.start(JSSProApplication.java:109)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

AttachmentSize
error.png53.62 KB
v6.0.1
Cutom Component
santhoshkolloju's picture
Joined: Jan 13 2015 - 9:27am
Last seen: 1 year 1 week ago

5 Comments:

#1
  • Assigned:»

This is probably due to the fact that your server is not supporting the custom visualization component.
You should check to have the jar jasperreports-customvisualization-6.0.1.jar (shipped inside Jaspersoft Studio).
You also have to specify in the jasperreports.properties file in your WEB-INF/classes the following properties:

com.jaspersoft.jasperreports.components.customvisualization.require.js=file://location/of/require.js
net.sf.jasperreports.web.resource.pattern.customvisualization.scripts=com/jaspersoft/jasperreports/customvisualization/resources/require/.*

You should adjust the location of require.js (available inside JasperReports Server).

Hope this helps,

Giulio

#2
  • Resolution:Open» Works as Designed
  • Status:New» Closed
  • Assigned:» anonymous

Here a step by step tutorial on how to add the custom visualization component to JRS. I suppose that you are on windows with JSS 6.0.3, JRS 6.0.1 and default installations path. I also provide the paths that i have on my windows machine, on the other OS they will change a bit.

- Found the jasperreports-customvisualization-6.0.1.jar (on my machine the path is C:\Program Files\TIBCO\Jaspersoft Studio-6.0.3.final\configuration\org.eclipse.osgi\bundles\23\1\.cp\lib\jasperreports-customvisualization-6.0.1.jar

- Copy the jar file inside the web-inf\lib folder of your jasperserver (C:\Jaspersoft\jasperreports-server-cp-6.0.1\apache-tomcat\webapps\jasperserver\WEB-INF\lib)

- Edit the file jaspereports.properties in web-inf\classes (C:\Jaspersoft\jasperreports-server-cp-6.0.1\apache-tomcat\webapps\jasperserver\WEB-INF\classes)

- Add the the two properties listed above (the path of require js should be C:\Jaspersoft\jasperreports-server-cp-6.0.1\apache-tomcat\webapps\jasperserver\optimized-scripts\bower_components\requirejs\require.js)

Stop and restart the server. After this the upload of report with the custom visualization component should work.

#3

I didnt work for me still same error

#4
  • Status:Closed» New
  • Assigned:anonymous»

Exception error is throwing while publishing report

AttachmentSize
error1.xlsx121.74 KB
#5

The error indicates that you the jrxml is not valid.
This can happen if:
1. The server does not have the extension to load the custom component
2. The server does have the extension, but it is outdated (we refactored a little bit the CVC in 6.2.0, this could have introduced something that the old extension does not like)

Giulio

Feedback