[#8536] - Logout button missing

Category:
Bug report
Priority:
Normal
Status:
New
Project: Severity:
Minor
Resolution:
Works as Designed
Component: Reproducibility:
Always
Assigned to:
0

The "Log out" button is missing in JR Server community 6.3.0 (installed from linux installer, CentOS 7, bundled Tomcat and Postgres). Client: Firefox 48.

Installed 3x for checking.

v6.3.0
skygge's picture
2
Joined: Sep 21 2016 - 4:37am
Last seen: 7 months 3 weeks ago

4 Comments:

#1

Are there any particular circumstances leading to this? e.g. user is redirected to error page or license failed paged?

#2

Fresh install, just copied "applicationContext-externalAuth-LDAP.xml" from previously installed v 6.2.0 to enable LDAP auth and after logging in the place where usually "Log Out" should be is empty. No errors on the screen, logs are clean. Users and roles are stored in LDAP. When login on "jasperadmin" account - "Log Out" button is on its place.
See: https://www.youtube.com/watch?v=OP68cq6iV5w

#3

Check if the user that comes from LDAP has the proper roles transferred (it needs to be a member of ROLE_USER).
It may also have something to do with the themes but since is a clean install I do not think so.

#4
  • Resolution:Open» Works as Designed

What i found is that if there is a user setup with Role Anonymous, the logout link automatically disappears . That's the jasperadmin has the link coming up. try editing the role and see if the issue still persists. This wasn't a problem in 6.1

Feedback