[#7961] - KeepTogether attribute failed with subgroups

Category:
Bug report
Priority:
Urgent
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

Hi! I'm new with JasperReports and I have a report with two groups. in the 1st group I have isReprintHeaderOnEachPage="true", and in the 2nd (The subgroup) keepTogether="true".
But when the header of the subgroup is printed on the bottom of the page, the keepTogether attribute doesn't work.

And it works fine with one group and the same Data.

You can find a screenshoot and my JRXML file bellow with the problem. Is there a way or an idea to fix this bug ?

I am using JasperReports 5.6.1 but I see the same bug in the least version !

AttachmentSize
keeptogether.png27.08 KB
testkeeptogether.jrxml21.1 KB
v6.2
yassine.mouhli.92's picture
Joined: Apr 20 2016 - 3:02am
Last seen: 1 year 2 weeks ago

7 Comments:

#1

any answer ??

#2
  • Priority:Normal» Urgent
  • Status:New» Assigned
  • Assigned:» teodord

Hi!
I have made some modifications in the JasperReports-5.6.1 source code (you can find a patch attached: jasperReportsKeepTogether.patch)
This patch fixes the KeepTogether attribute, which is bug with multiples groups and subGroups that have the keepTogether="true" and isReprintHeaderOnEachPage="true".
So let me know if my changes are useful or if it breaks any other functions in jasper ?

Thanks !

AttachmentSize
jasperreportskeeptogether.patch1.49 KB
#3

Hi,

Is there some news about this patch ?
Is it validated ? Integrated in the last version ?

#4

Hi,

Someone can review this patch ?
I think it's working and hope it can be merged to have it in upstream version.

#5

Hi,

Is there someone to review this patch ?

#6

Hi,

We are looking into this. So far, the problem seems to be more complex and the provided patch would not fully solve it. We'll let you know how it goes.

Thanks,
Teodor

#7
  • Resolution:Open» Fixed
  • Status:Assigned» Resolved

Hi,

This is now fixed on the master branch of our Git repository and will be available in the next release.
Please give it a try if you can and let us know how it goes.

Thanks,
Teodor

Feedback
randomness