[#2703] - Crystal Reports converter

Category:
Feature request
Priority:
Low
Status:
New
Project: Severity:
Trivial
Resolution:
Won't Fix
Component: Reproducibility:
Always
Assigned to:
0

Issue moved from:
https://sourceforge.net/tracker/index.php?func=detail&aid=678487&group_i...

Consult the original issue for any attachments.

[ 678487 ] Crystal Reports converter

Submitted By: Nobody/Anonymous - nobody
Date Submitted: 2003-01-31 16:56
Last Updated By: nobody - Comment added
Date Last Updated: 2003-01-31 17:11
Number of Comments: 1
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
Crystal Reports converter

Create a converter that handles Crystal .rpt files and generates Jasper files. A) This will definately give a huger user base quickly as most people are unhappy with crystal, especially licensing wise B) If you do everything that Crystal does you are on the
right track C) Will demonstrate what not to do since Crystal tends to do that a lot.

The Crystal RDC API is very open. You do not need to open the file manually and reverse engineer it. It would require that the person converting the files have a license to Crystal, but chances are they would. A demo can be downloaded that is fairly functional. The developer suite itself can usually be purchased for about $200 to $400 depending on specials and which bundle you get.

Comments

Date: 2003-01-31 17:11
Sender: nobody
Logged In: NO

One more thing, it would also give some breathing room to get JasperDesign up and going. Users could use Crystal to design and test the reports and then use Jasper to deploy.

No Files Currently Attached

tcloonan's picture
423
Joined: Dec 22 2006 - 1:13am
Last seen: 10 years 5 months ago

5 Comments:

#1
  • Resolution:Open» Won't Fix
  • Status:Acknowledged» Resolved

Hi,

We'll never create such converter ourselves.

Thanks,
Teodor

#2

I see that the original question is very old and the response is also quite old. But if the respondent still monitors this group my question is this:
If one already was able to extract crystal reports into SSRS/RDL XML format - how hard would it be to output Jasper XML instead?
How close are the two formats? I cannot find too much posted recently about the similarities between RDL and JRXML, except for decades ago postings that imply that RDL and Jasper format is very close. Is this still true?

#3
  • Status:Resolved» New

Hi I'm trying to convert from Crystal reports (.rpt) to Jasper, and I have the same doubts as you. Did you finally find a way to accomplish it?

#4

I would love to see a tool which converts the Crystal report XML file to a Jaspersoft jrXML file.

#5
AttachmentSize
avisodecobro.rpt170.5 KB
Feedback
randomness